Spring Security CAS plugin. 1.0.4 doesn't work, 1.0.2 works

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Spring Security CAS plugin. 1.0.4 doesn't work, 1.0.2 works

A Kumar
Hi .

We are trying to integrate Spring security and CAS plugins. We are seeing an issue with version 1.0.4 of the spring-security-cas. The secure page directs us to the Spring security login screens and not the CAS login screen. With 1.0.2 it works fine and we get re-directed to CAS and login+logout works.

I did some investigation and I think the order of initialization of the plugins is an issue.
Order for 1.0.2 is :

Configuring Spring Security Core ...
... finished configuring Spring Security Core

Configuring Spring Security CAS ...
| Server running. Browse to http://localhost:8080/grailsortments

Order for 1.0.4 is just the reverse. In both cases, the groovy configuration files are identical. We are using grails 2.0.4 and JDK 6.

I spent a lot of time in debugging this issue and wanted to share this to see if people have seen similar behavior.

Amit
Reply | Threaded
Open this post in threaded view
|

Re: Spring Security CAS plugin. 1.0.4 doesn't work, 1.0.2 works

Burt Beckwith
Administrator
I've released version 1.0.5 with this fixed - please try that out.

Burt

A Kumar wrote
Hi .

We are trying to integrate Spring security and CAS plugins. We are seeing an issue with version 1.0.4 of the spring-security-cas. The secure page directs us to the Spring security login screens and not the CAS login screen. With 1.0.2 it works fine and we get re-directed to CAS and login+logout works.

I did some investigation and I think the order of initialization of the plugins is an issue.
Order for 1.0.2 is :

Configuring Spring Security Core ...
... finished configuring Spring Security Core

Configuring Spring Security CAS ...
| Server running. Browse to http://localhost:8080/grailsortments

Order for 1.0.4 is just the reverse. In both cases, the groovy configuration files are identical. We are using grails 2.0.4 and JDK 6.

I spent a lot of time in debugging this issue and wanted to share this to see if people have seen similar behavior.

Amit
Reply | Threaded
Open this post in threaded view
|

Re: Spring Security CAS plugin. 1.0.4 doesn't work, 1.0.2 works

A Kumar
Version 1.0.5 worked without any issue.
Appreciate the prompt response!!