Bug in UI Performance Plugin when Deploy WAR

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug in UI Performance Plugin when Deploy WAR

strayph
After fixing: http://grails.1312388.n4.nabble.com/FIXED-WAR-not-showing-resources-tc3571777.html

Basically, create a new Grails project, install the UI Performance Plugin, create a WAR, and run from Tomcat.

You don't see any of your resources (images, css, javascript).

Strayph

I tested with STS and tc Server 2.1, and also Tomcat 6 running on Ubuntu under some AMI on Amazon.
Reply | Threaded
Open this post in threaded view
|

Re: Bug in UI Performance Plugin when Deploy WAR

Burt Beckwith
Administrator
By "you don't see" do you mean that they're not in the war, or you're getting 404s? You need to switch to the plugin's tags which are aware of the rename based on gzip and version, e.g. <p:javascript>, <p:css>, <p:image>. See http://grails.org/plugin/ui-performance

Burt

strayph wrote
After fixing: http://grails.1312388.n4.nabble.com/FIXED-WAR-not-showing-resources-tc3571777.html

Basically, create a new Grails project, install the UI Performance Plugin, create a WAR, and run from Tomcat.

You don't see any of your resources (images, css, javascript).

Strayph

I tested with STS and tc Server 2.1, and also Tomcat 6 running on Ubuntu under some AMI on Amazon.
Reply | Threaded
Open this post in threaded view
|

Re: Bug in UI Performance Plugin when Deploy WAR

strayph
The resources are in the war, but give 404s on request. 

What is strange to me is that it works with 'grails run-app' but not as war. Why is that?

I understand that maybe it was wrong of me to assume I could install a plugin  and it wouldn't change the behavior. It should. 

The problem in this case though is that the changed behavior only occurred after deploying as a war, which made it difficult to associate the 404s with the installation of the plugin. 

Sent from my iPhone

On Jun 4, 2011, at 8:21 AM, "Burt Beckwith [via Grails Plugins]" <[hidden email]> wrote:

By "you don't see" do you mean that they're not in the war, or you're getting 404s? You need to switch to the plugin's tags which are aware of the rename based on gzip and version, e.g. <p:javascript>, <p:css>, <p:image>. See http://grails.org/plugin/ui-performance

Burt

strayph wrote:
After fixing: http://grails.1312388.n4.nabble.com/FIXED-WAR-not-showing-resources-tc3571777.html

Basically, create a new Grails project, install the UI Performance Plugin, create a WAR, and run from Tomcat.

You don't see any of your resources (images, css, javascript).

Strayph

I tested with STS and tc Server 2.1, and also Tomcat 6 running on Ubuntu under some AMI on Amazon.



If you reply to this email, your message will be added to the discussion below:
http://grails-plugins.847840.n3.nabble.com/Bug-in-UI-Performance-Plugin-when-Deploy-WAR-tp3022054p3023420.html
To unsubscribe from Bug in UI Performance Plugin when Deploy WAR, click here.